Simul Support ExchangeCategory: Clouds4.27 Cloud movement not smooth
asked 3 weeks ago

Animating clouds simply using the TrueSkySequence, adding the keyframes like in the tutorials. Running the latest 4.27 version.
Even setting the Amortization to 1 the movement of the clouds only happens in steps, choppy, not smooth. 
I have watched all the tutorials and unable to fix this. We have a deadline and this is really important to get fixed soon.
Could anyone from the team step in and help?

stamisme replied 1 week ago

im just a user of the plugin but generally its due to the new interpolation method in truesky, so basically, you’re kinda fucked.

replied 1 week ago

The plugin clearly does not work as advertised, this breaks the usability of any cloud animation. They market the animation capability in their Youtube channel, but it doesn’t work.
Also I didn’t get support from the creator, this only ended up causing mess in our project.

1 Answers
James Evans Staff answered 3 weeks ago

Hi,

Apologies for the issues you are having.

Could you please send an example video of these issues? 

Regards, James

replied 3 weeks ago

Hi,
Sure. The video is here.
https://1drv.ms/v/s!AgSCCot8A-5pj-E28G-zHazQ2I2J_g?e=PZB82m
What I have done is only created a keyframe in TrueSkySequence asset.
I am running RTX3090

replied 1 week ago

I would expect support for a plugin that is marketed as a professional tool.
Because we didn’t receive support we needed to switch to another solution.

James Evans Staff replied 6 days ago

I sincerely apologise for the delay – we are a small team and we do our best to reply as quickly as possible.

Is this movement via wind or movement via the keyframe position?

replied 6 days ago

Ok, thanks.
As I said in first post, keyframe position.

replied 6 days ago

Did you see the video I posted? As I wrote 2 weeks ago
“What I have done is only created a keyframe in TrueSkySequence asset.”
https://1drv.ms/v/s!AgSCCot8A-5pj-E28G-zHazQ2I2J_g?e=PZB82m

James Evans Staff replied 6 days ago

For issues with manual keyframe positioning, try adjusting the interpolation setting within the trueSKY actor, such as the subdivisions, or see if a different interpolation mode works better for you. The stepping in the example you sent is very severe and unusual, so I believe some adjustments would help.

We are aware manual positioning can cause a stepping effect, and we have been working on a solution, which we will release as soon as it is ready. If Global wind movement can be used in your project, this will not cause the stepping effect. To use this, disable the manual positioning option on the cloud layer and use the wind speed variable within the trueSKY actor, making sure there is some progression to the trueSKY Time.

We will hopefully be able to get a complete fix for this issue soon.

Regards,

James