Simul Support ExchangeCategory: CloudsSet Cloudiness not work
keji wu asked 7 months ago

I use UE4.27, and my truesky plugin is the latest version(4.3), My licence has actived.
I use SetCloudKeyframeValue node to set cloudiness, when the value change the cloud in scene is not any different, and I set to 0, the cloud disappeared, then I set to other value, the cloud appeared and is the same with the game not start state.
Whether there are some important settings should I made or in fact I should use other way to set cloud property?

1 Answers
Best Answer
James - Simul Support Staff answered 7 months ago

Hi Keji,

What keyframe are you changing? We recommend you change the next modifiable keyframe, we should have a blueprint to get the “next modifiable keyframe”. The clouds visible will be generated by interpolating the previous and next keyframe, so adjusting these at runtime will result in non-smooth interpolation if for example you went from 0.3 to 1.0 cloudiness. The next modifiable keyframe would be a keyframe that is not being used to generate the currently interpolated clouds.

Regarding your issue, for keyframe changes to take affect at runtime you will need to be progressing the trueSKY time. Our check for 0 cloudiness is a performance improvement for when there are no clouds, but it is incorrect and should not adjust the clouds immediately, which I will look into. 

Thanks,

keji wu replied 7 months ago

Thanks for reply,

The keyframe is cloud, and I have tried use node that you say, but stil not work.
I recorded two videos maybe more intuitive, files in this link: https://1drv.ms/f/s!AvmS9beZV9phiQfrYIVywXZ0HHm4?e=YStHfN

After you watch, tell me where the mistake I made. plz

I feel very confusing because none of these issues exist in the lower versions(UE4.24 and truesky 4.2)

James - Simul Support Staff replied 7 months ago

Your first blueprints look fine, what is your progression scale in this scene? In old 4.2 we inefficiently updated the clouds every frame, whereas with newer versions we update the clouds internally over a period of time and then update the scene once complete. So to see immediate change, try increasing your progression scale on the actor.
I can understand the confusion between the older version, and we’re working on making it more intuitive in a future update.

Your second example with multiple keyframes has an issue when setting the time. You are using our internal set time function, which expects time for the first day to be between 0-1. So 0.5 would me mid-day on day 1, and 1.5 would be mid-day on day 2. Check the hover tooltip for more information. You can either continue to use that blueprint and add our “time to trueSKY time” blueprint first, to convert the time units to the trueSKY format. Or alternatively, just directly set the variable on the trueSkyActor using your preferred units.

Here is a quick example, I have included both methods for setting time – https://imgur.com/a/FbprJdI

keji wu replied 6 months ago

OK , my fault, I just noticed “Progression Scale” is the same thing as “Time Factor” in 4.2
As you say, just set this value to 60 or more could see cloud change immediately, but results is if I need a fixed time after set the new time, I have to set the time continually, if the “Progression Scale” value is to small I won’t see change, In 4.2 this value can be very small.
Anyway, looking forward to a better effect for the new version