Simul Support ExchangeCategory: External Plugin IssuesWhen do you plan for TrueSKY to support UE5?
Kazuki Wada asked 1 month ago

I have been using TrueSKY since UE4.18.
I am working on a new game with UE5.0. When do you expect TrueSKY to “officially” support UE5?
I know a similar question was posted 10 months ago, but I would like to know the current progress and status of the project.

Simen Leth replied 4 weeks ago

Lets upvote this… Love the truessky product, but its becoming useless for us as we move towards UE5

1 Answers
Wayne Littler Staff answered 4 weeks ago

trueSKY for UE5 (Beta) is now available for download via https://simul.co/downloads. Any issues should be reported via https://simul.co/support/exchange/ or  https://simul.co/account/bug-report/